Error on compilation of examples in dspic toolbox

Post Reply
Posts: 1
Joined: Fri Nov 04, 2011 9:24 am

Error on compilation of examples in dspic toolbox

Post by sujitha » Fri Nov 04, 2011 9:49 am

Hi everyone,

I have matlab2006a installed with Simulink version 6.4,Real-Time Windows Target version 2.6.1, Real-Time Workshop version 6.4 and Real-Time Workshop Embedded Coder 4.4.

I have downloaded and installed the "dspic toolbox for matlab 2006a" from the link

The installation of the toolbox is completed. When i run the following command to check the perfect installation of the toolbox, i got error.

cd examples

The error which i have obtained is "Error evaluating 'openfcn' callback of master function. RTW system target must be defined to dspic.tlc.

But the simulink->configuration parameters -> real time workshop -> system target file is already pointing dspic.tlc only.

!gake command and !pic30-gcc and !pic30-gcc -v command are normal. (as per many errors discussed in the forum)

I have MPLAB c30 compiler student version 3.11b installed in the system.

I have worked with corresponding blocksets in matlab 2007a and 2010a. I didn't get any problem like this. So i cant conclude that this maybe the problem of compiler.

Anybody help me to overcome this problem???????????

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest