I2C problem on UDB4 board

Post Reply
Posts: 12
Joined: Mon Dec 19, 2011 11:32 am

I2C problem on UDB4 board

Post by alpert » Wed Jan 25, 2012 7:35 pm

Hello Lubin,
I'm using the Sparkfun's UDB4 board.
I've tried to make his I2c to work and I bump into something strange.

[ Before i'll continue, just for the protocol, I have already tested the I2C block on GlounPilot's board (dsPIC33fj256jMC710) and it worked fine ] .

So, here is the problem:
This board have 2 port of I2C. One suppose to be used by the EEPROM and the other is free to connect. Both ports are connected to PULL-UP resistors on the board.
I've made a simple model which use I2C_2 and sends a constant number to a constant address every 0.1 sec. here is the model:
(36.86 KiB) Downloaded 179 times
After that, I have touched with a scope on I2C_1 (mark as (1) on the picture) and I2C_2 and i found out that they both show the same signal (its a bad signal, but i'll keep this problem for the next topic).

After that i changed th model to I2C_1 and no signal appear on both ports (i have tried to touch directly on the PULL-UP).

Here is a picture of the board, i marked the I2C_1 and I2C_2 and the PULL-UP resistors:
I2C.jpg (62.2 KiB) Viewed 2391 times
Lubin, can you please test it on your board?


Posts: 12
Joined: Mon Dec 19, 2011 11:32 am

Re: I2C problem on UDB4 board

Post by alpert » Thu Feb 09, 2012 4:31 pm

OK. Problem solved after clicking on "Erase flash device" in MPLAB.
Mybe the problem has occur because the MPLAB's programer set to "Allow PICkit 3 to select memories and ranges" and from some reason it didn't update all the registers (Lubin, is it a possible explanation?)

Now there is another problem with the I2C, but i will start a new topic for it.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests