Bug, or Matlab needs P4 instruction set, or...

Post Reply
Posts: 3
Joined: Tue May 22, 2007 10:21 pm

Bug, or Matlab needs P4 instruction set, or...

Post by andor » Sun May 27, 2007 4:35 pm

I try to describe my problem:

There is an interesting thing I’ve found I think it is a bug (but I don’t know whether Matlab or the toolbox has it). Firstly I tried the toolbox on my computer, I only do the basic things (ex. the demonstration things on your webpage and some more) and it worked (it is a must to change the character encoding with set_param(…), but it’s OK). Next I tried to design a control loop on a laptop but there were some problems even if I tried to build the demonstration example found on your web page. I can only guess that this is because the laptop has a Celeron 1200 MHz processor (Pentium 3 instruction set) and my PC has P4 instruction set (I’m not sure because I haven’t seen the real operation). When I completed set the parameters of the model (time step, solver) I tried to configure the master block (double click), but I got the following error message:

"Error evaluating ‘OpenFcn’ callback of Master block (mask) ‘Untitled/Master’. Error using ==> <a href=”error:C:\MatdsPIC\blocks\dsPIC_MASTER_callback.p,30,1”> dsPIC_MASTER_callback at 30 </a>

Corrupted package, Remove and Re-install dsPic embedded Target toolbox."

Probably you’ve figured out that the project name was ‘Untitled’, and the installation path was ‘C:\MatdsPIC’.

As far as I know Matlab needs P4 instruction set, but I haven’t met this problem before (and we don’t have P4 laptop).
I don't understand why, but according to the Marhworks webpage Matlab needs P4 or above:
http://www.mathworks.com/support/sysreq ... t_release/
but once I've downloaded a Unix installation guide that had specified p3 and above. Strange...
By the way the laptop has 512 MB memory that meets the requirements, the PC has even more.

I tried to reinstall the toolbox, even I reinstalled Matlab and the toolbox from scratch but the same thing happened. Because the clean installation, The laptop and my PC has the same settings.

Site Admin - Expert
Posts: 616
Joined: Wed Mar 07, 2007 11:23 pm
Location: Bayonne- France

Post by LubinKerhuel » Sat Jun 09, 2007 11:50 am

Hi andor,

This is weird. Does anybody encounter the same problem ? I do not think it is in relationship with the processor. Either an unknow bug remains in the toolbox (please, if you get the same error, repport it) neither the toolbox is not properly installed. Try to check the installation :

The installer m file should add the two subdirectory created:
- *\dspic
- *\blocks
In the matlab path.
-->Check that this has been done correctly:
in matlab : File ==> set path and check that the theses two directory are present. If they are not, add them...

It still doesn't work:
Try to refresh the matlab path cache if it is enable ; disable the path cache:
File ==> Preferences ==> in the General Tab...

It still doesn't work?
The toolbox must not be installed in the matlab directory or subdirectory. Make sure you did not install the toolbox inside the matlab directory or sudirectory !


Posts: 3
Joined: Tue May 22, 2007 10:21 pm

Post by andor » Sat Jun 23, 2007 5:09 am


I tried everything you mentioned but the problem remained...

It is interesting because I configured everything (solver and the dsPIC.tlc)

Here is the log that Matlab gived when I tried to configure the Master block:

Warning: Error evaluating 'CopyFcn' callback of Master block (mask) 'Master'. Error using ==> dsPIC_ConfigRTWOption at 34
The *System Target File must be defined to dsPIC Real Time workshop (Simulation ==> Configuration Parameters ==> Real Time workshop.
Warning: The dialog of 'untitled/Master' is being closed because a mask parameter has been changed.
> In C:\0dsPICMat\blocks\dsPIC_Set_Dialog_PopUp_Param.p>dsPIC_Set_Dialog_PopUp_Param at 57
In C:\0dsPICMat\blocks\dsPIC_MASTER_callback_InitMask.p>dsPIC_MASTER_callback_InitMask at 222
### Starting Real-Time Workshop build procedure for model: untitled
### Generating code into build directory: C:\Documents and Settings\Andor\Dokumentumok\MATLAB\untitled_dspic\sources
### Real-Time Workshop build procedure for model: 'untitled' aborted due to an error.

Maybe it is because of the (deleted) older version but I can't get myself trough... Maybe a total PC reinstall would help...

Here is the error message I got after double clicking the master block:
Here is the error message I got after I tried to adjust the paramters by right click -> mask parameters:
And I got the configuration block but it's a little bit strange:

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest