Failed compilation still generated MPLAB 8 project

bmairs
Posts: 69
Joined: Mon Jul 27, 2009 7:51 pm

Failed compilation still generated MPLAB 8 project

Postby bmairs » Mon Jan 16, 2012 8:40 pm

If my project fails compilation then a .mcp file for MPLAB 8.x is still generated.

LubinKerhuel
Site Admin - Expert
Posts: 616
Joined: Wed Mar 07, 2007 11:23 pm
Location: Marseille - France
Contact:

Re: Failed compilation still generated MPLAB 8 project

Postby LubinKerhuel » Mon Jan 16, 2012 9:13 pm

Hi Bryant,

This is done on purpose : It allows to find out why compilation breaks. For example, if the blockset mispell one fuse register, you might correct it this way quite easily.
However, depending where the compilation stops, you might have missing files...

Lubin

bmairs
Posts: 69
Joined: Mon Jul 27, 2009 7:51 pm

Re: Failed compilation still generated MPLAB 8 project

Postby bmairs » Tue Jan 17, 2012 8:34 pm

But there isn't a similarly compiled MPLAB X project, which is why I assumed this was a bug. I'd prefer to switch over to X whenever possible, so could you also make the MPLAB X project be generated?

LubinKerhuel
Site Admin - Expert
Posts: 616
Joined: Wed Mar 07, 2007 11:23 pm
Location: Marseille - France
Contact:

Re: Failed compilation still generated MPLAB 8 project

Postby LubinKerhuel » Wed Jan 18, 2012 9:33 pm

Bryant, I am a bit confused.

Could you described what you obtained and what you would like to obtain ?
(I am not sure I could do it for this blockset, but it would be useful for next Microchip blockset)

Currently, the model
- generates a .mcp file (mplab 8 project) and
- add into the directory created (with almost similar name than the model) the information for the mplab X project : nbproject folder and files...

Thus with mplab X, you should be able to open that folder which is the project (browse the folder with MPLAB X, you will see that folder icon is like a project).
MPLAB X does not provide one "clikable" file that would allows opening the project.

Lubin

bmairs
Posts: 69
Joined: Mon Jul 27, 2009 7:51 pm

Re: Failed compilation still generated MPLAB 8 project

Postby bmairs » Tue Jan 24, 2012 12:58 am

If I build a project and it fails compilation an MPLAB 8 project is generated but NOT an MPLAB X project. I just thought it was weird that a project was generated for only one of the IDEs and not both. I figured it was a bug because you'd either want no project to be generated when compilation failed or for both projects to be generated regardless of whether compilation fails or not, but what's happening is in between.


Return to “bug reports”

Who is online

Users browsing this forum: No registered users and 1 guest