MPLAB 8.x project not generated properly during compile

Post Reply
bmairs
Posts: 69
Joined: Mon Jul 27, 2009 7:51 pm

MPLAB 8.x project not generated properly during compile

Post by bmairs » Mon Nov 07, 2011 8:25 pm

I'm compiling a project and the MPLAB 8.x project isn't being properly generated. I'm seeing the following at the end of code generation:

Code: Select all

"    ---33fJ256GP710---" 
"*** Created "executable": ..\../code_gen.cof"	 
''pic30-bin2hex ..\../code_gen.cof  
"*** Converted code_gen.cof to code_gen.hex"	 
. 
"***  MPLAB: file -> import, choose code_gen.hex. Configure -> Configuration Bits : Verify !" 
"       Download into the chip and run."		 
### Successful completion of Real-Time Workshop build procedure for model: code_gen
***  You could open project created and (re)compile it :
   	  ==> MPLAB 8: Within Matlab, right-click code_gen.mcp -> open outside Matlab.
   	  ==> MPLAB X: Start MPLAB X, then open the project folder C:\Users\Bryant\Projects\Autoboat\Code\basic_model\code_gen_dspic
The path '\circBuffer.c' does not exist

Warning : MPLAB project not created due to internal error
My project does include a variety of external C files, though none have the path '\circBuffer.c':

Code: Select all

clib/conversions.c
clib/nmea0183.c
clib/nmea2000.c
clib/ecanSensors.c
clib/gps.c
clib/revo.c
clib/commProtocol.c
clib/uart1.c
clib/uart2.c
clib/DEE.c
clib/DEES.s
clib/misc.c
../../../ECAN_dspic/circBuffer.c
../../../ECAN_dspic/ecanFunctions.c
I've also played with location of circBuffer.c within the list of files to include and it made no difference whether it was at the head of the list or towards the bottom.

I have also tried opening the MPLAB X project, but it looks like it doesn't delete them before regeneration, so it isn't generating new MPLAB X projects either.

LubinKerhuel
Site Admin - Expert
Posts: 616
Joined: Wed Mar 07, 2007 11:23 pm
Location: Bayonne- France
Contact:

Re: MPLAB 8.x project not generated properly during compile

Post by LubinKerhuel » Mon Dec 05, 2011 11:26 am

Hello Bryant,

I tested a tiny model with two c files declared as follow: (Code Generation - Custom Code - additional Source files):

Code: Select all

..\..\CFunctionCall\MyCFunction.c
test/myfunction2.c
I could not reproduce the problem.

Which blockset version do you currently have ?

Lubin

bmairs
Posts: 69
Joined: Mon Jul 27, 2009 7:51 pm

Re: MPLAB 8.x project not generated properly during compile

Post by bmairs » Tue Dec 06, 2011 10:45 pm

I have version 3.66b. I'm also seeing compilation work for some other projects that I have, so it seems specific to this one.

LubinKerhuel
Site Admin - Expert
Posts: 616
Joined: Wed Mar 07, 2007 11:23 pm
Location: Bayonne- France
Contact:

Re: MPLAB 8.x project not generated properly during compile

Post by LubinKerhuel » Tue Dec 06, 2011 10:57 pm

I might test compiling your project on my system if that's not too huge.

Lubin

bmairs
Posts: 69
Joined: Mon Jul 27, 2009 7:51 pm

Re: MPLAB 8.x project not generated properly during compile

Post by bmairs » Sat Dec 10, 2011 1:36 am

You'll need to add the two non-Autoboat directories to the matlab path. The actual model is in \Autoboat\Code\basic_model.
Attachments
Projects.zip
(307.9 KiB) Downloaded 195 times

resodad
Posts: 71
Joined: Tue Jul 07, 2009 1:06 pm
Location: West Point, New York

Re: MPLAB 8.x project not generated properly during compile

Post by resodad » Tue Jan 10, 2012 1:33 pm

Bryant,
I get this error:
"
The following error occurred processing the System Target File '':
Undefined function or variable "version".
"
when I build.
John

bmairs
Posts: 69
Joined: Mon Jul 27, 2009 7:51 pm

Re: MPLAB 8.x project not generated properly during compile

Post by bmairs » Thu Jan 12, 2012 3:36 am

This was fixed for me in the new 3.7b release.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest