PTsources files not found. MPLAB project file not created.

abrixy
Posts: 3
Joined: Mon Sep 19, 2011 9:40 pm

PTsources files not found. MPLAB project file not created.

Postby abrixy » Mon Sep 19, 2011 9:58 pm

I my name is Sandra from Belgium

I would like to test the Blockset with the Explorer 16 board and a DSpic33.

But I already made 2 install one, on XP and on Vista

and i always have the same problem it seems not see the compiler but they are both installed :

>>!pic30-lm
Microchip MPLAB C30 License Manager Version v3_25 (Build Date Oct 11 2010).
Copyright (c) 2008 Microchip Technology Inc. All rights reserved.
Academic license for MPLAB C for 16-bit devices,
does not expire.
This demo-version license for MPLAB C for dsPIC devices,
has expired.

When I launch compilation the command window give me this message :

PTsources files not found. MPLAB project file not created.
sources files not found. MPLAB project file not created.

and i get a error in the pop-up window

Error building Real-Time Workshop target for block diagram 'dsPIC_33f_Explorer16'. MATLAB error message:
Error using ==> make_rtw
Too many output arguments.

My configuration is MATLAB7.50(R2007B) so i used this script to install : install_dsPIC_R2007b.m

I tried to install with and without administrator rights on vista + a test on XP
Nothing seems to work
it just create me a slprj directory but no .HEX
I'm used to generate c code for simulink but i have no experience to compile it into MATLAB

Thanks Sandra

LubinKerhuel
Site Admin - Expert
Posts: 616
Joined: Wed Mar 07, 2007 11:23 pm
Location: Marseille - France
Contact:

Re: PTsources files not found. MPLAB project file not create

Postby LubinKerhuel » Wed Sep 21, 2011 7:34 am

Hi Sandra,

Could you post the complete message you get when compilint (all lines written at matlat command windows).
Are you compiling a model from the example directory or is it your own model ? if so, please upload it on the forum.

Lubin

abrixy
Posts: 3
Joined: Mon Sep 19, 2011 9:40 pm

Re: PTsources files not found. MPLAB project file not create

Postby abrixy » Wed Sep 21, 2011 3:21 pm

Hi,

there is not much info on the console when compiling

>> sources files not found. MPLAB project file not created.

+ the error window :

Error building Real-Time Workshop target for block diagram 'dsPIC_33f_Explorer16'. MATLAB error message:
Error using ==> make_rtw
Too many output arguments.


I do open an compile an example model for explorer 16. "dsPIC_33f_Explorer16"

this is the console log when i open the model.:

Code: Select all

>>

Warning: Could not find an exact (case-sensitive) match for 'ExecBatch'.
D:\work\dspic\execBatch.p is a case-insensitive match and will be used instead.
You can improve the performance of your code by using exact
name matches and we therefore recommend that you update your
usage accordingly. Alternatively, you can disable this warning using
warning('off','MATLAB:dispatcher:InexactMatch').
> In C:\Program Files\MATLAB\R2007b\toolbox\rtw\rtw\private\getSTFInfo.p>getSTFInfo at 73
  In C:\Program Files\MATLAB\R2007b\toolbox\rtw\rtw\rtwprivate.p>rtwprivate at 12
  In C:\Program Files\MATLAB\R2007b\toolbox\rtw\rtw\stf4target.p>stf4target at 35
  In C:\Program Files\MATLAB\R2007b\toolbox\rtw\rtw\stf2target.p>stf2target at 61
  In general\private\openmdl at 13
  In open at 148
  In uiopen at 196
Warning: dsPICdrivers.mdl, line 50: block_diagram does not have a parameter named
'CovForceBlockReductionOff'.
> In general\private\openmdl at 13
  In open at 148
  In uiopen at 196
Warning: dsPICdrivers.mdl, line 55: block_diagram does not have a parameter named
'CovModelRefEnable'.
> In general\private\openmdl at 13
  In open at 148
  In uiopen at 196
Warning: dsPICdrivers.mdl, line 56: block_diagram does not have a parameter named
'CovExternalEMLEnable'.
> In general\private\openmdl at 13
  In open at 148
  In uiopen at 196
Warning: GMAKE_PLACE not defined, check tlc target
> In D:\work\blocks\dsPIC_ConfigRTWOption.p>dsPIC_ConfigRTWOption at 45
  In D:\work\blocks\dsPIC_MASTER_callback.p>dsPIC_MASTER_callback at 87
  In D:\work\blocks\dsPIC_UART_Rx_Tx_Matlab_InitMask.p>dsPIC_UART_Rx_Tx_Matlab_InitMask at 9
  In general\private\openmdl at 13
  In open at 148
  In uiopen at 196
Warning: The *System Target File must be defined to dsPIC Real Time workshop (Simulation
==> Configuration Parameters ==> Real Time workshop
> In D:\work\blocks\dsPIC_ConfigRTWOption.p>dsPIC_ConfigRTWOption at 408
  In D:\work\blocks\dsPIC_MASTER_callback.p>dsPIC_MASTER_callback at 87
  In D:\work\blocks\dsPIC_UART_Rx_Tx_Matlab_InitMask.p>dsPIC_UART_Rx_Tx_Matlab_InitMask at 9
  In general\private\openmdl at 13
  In open at 148
  In uiopen at 196
PWarning: --- =========>  PORT A0 is used by at least two peripheral :  UART Rx and
UART Tx.
> In D:\work\blocks\dsPIC_PortSetting.p>setTypePort at 638
  In D:\work\blocks\dsPIC_PortSetting.p>dsPIC_PortSetting at 124
  In D:\work\blocks\dsPIC_MASTER_callback.p>dsPIC_MASTER_callback at 89
  In D:\work\blocks\dsPIC_UART_Rx_Tx_Matlab_InitMask.p>dsPIC_UART_Rx_Tx_Matlab_InitMask at 9
  In general\private\openmdl at 13
  In open at 148
  In uiopen at 196
Warning: --- =========>  PORT A0 is used by at least two peripheral :  UART Rx and
Output Compare.
> In D:\work\blocks\dsPIC_PortSetting.p>setTypePort at 638
  In D:\work\blocks\dsPIC_PortSetting.p>dsPIC_PortSetting at 182
  In D:\work\blocks\dsPIC_MASTER_callback.p>dsPIC_MASTER_callback at 89
  In D:\work\blocks\dsPIC_UART_Rx_Tx_Matlab_InitMask.p>dsPIC_UART_Rx_Tx_Matlab_InitMask at 9
  In general\private\openmdl at 13
  In open at 148
  In uiopen at 196
Warning: --- =========>  PORT A0 is used by at least two peripheral :  UART Rx and PWM
Output Compare.
> In D:\work\blocks\dsPIC_PortSetting.p>setTypePort at 638
  In D:\work\blocks\dsPIC_PortSetting.p>dsPIC_PortSetting at 199
  In D:\work\blocks\dsPIC_MASTER_callback.p>dsPIC_MASTER_callback at 89
  In D:\work\blocks\dsPIC_UART_Rx_Tx_Matlab_InitMask.p>dsPIC_UART_Rx_Tx_Matlab_InitMask at 9
  In general\private\openmdl at 13
  In open at 148
  In uiopen at 196
Warning: --- =========>  PORT A0 is used by at least two peripheral :  UART Rx and
ADC.
> In D:\work\blocks\dsPIC_PortSetting.p>setTypePort at 638
  In D:\work\blocks\dsPIC_PortSetting.p>dsPIC_PortSetting at 281
  In D:\work\blocks\dsPIC_MASTER_callback.p>dsPIC_MASTER_callback at 89
  In D:\work\blocks\dsPIC_UART_Rx_Tx_Matlab_InitMask.p>dsPIC_UART_Rx_Tx_Matlab_InitMask at 9
  In general\private\openmdl at 13
  In open at 148
  In uiopen at 196
Warning: --- =========>  PORT A0 is used by at least two peripheral :  UART Rx and
Change Notification.
> In D:\work\blocks\dsPIC_PortSetting.p>setTypePort at 638
  In D:\work\blocks\dsPIC_PortSetting.p>dsPIC_PortSetting at 311
  In D:\work\blocks\dsPIC_MASTER_callback.p>dsPIC_MASTER_callback at 89
  In D:\work\blocks\dsPIC_UART_Rx_Tx_Matlab_InitMask.p>dsPIC_UART_Rx_Tx_Matlab_InitMask at 9
  In general\private\openmdl at 13
  In open at 148
  In uiopen at 196
Warning: --- =========>  PORT A0 is used by at least two peripheral :  UART Rx and SPI
In.
> In D:\work\blocks\dsPIC_PortSetting.p>setTypePort at 638
  In D:\work\blocks\dsPIC_PortSetting.p>dsPIC_PortSetting at 331
  In D:\work\blocks\dsPIC_MASTER_callback.p>dsPIC_MASTER_callback at 89
  In D:\work\blocks\dsPIC_UART_Rx_Tx_Matlab_InitMask.p>dsPIC_UART_Rx_Tx_Matlab_InitMask at 9
  In general\private\openmdl at 13
  In open at 148
  In uiopen at 196
Warning: --- =========>  PORT A0 is used by at least two peripheral :  UART Rx and SPI
Out.
> In D:\work\blocks\dsPIC_PortSetting.p>setTypePort at 638
  In D:\work\blocks\dsPIC_PortSetting.p>dsPIC_PortSetting at 333
  In D:\work\blocks\dsPIC_MASTER_callback.p>dsPIC_MASTER_callback at 89
  In D:\work\blocks\dsPIC_UART_Rx_Tx_Matlab_InitMask.p>dsPIC_UART_Rx_Tx_Matlab_InitMask at 9
  In general\private\openmdl at 13
  In open at 148
  In uiopen at 196
Warning: --- =========>  PORT A0 is used by at least two peripheral :  UART Rx and SPI
Clock Output.
> In D:\work\blocks\dsPIC_PortSetting.p>setTypePort at 638
  In D:\work\blocks\dsPIC_PortSetting.p>dsPIC_PortSetting at 350
  In D:\work\blocks\dsPIC_MASTER_callback.p>dsPIC_MASTER_callback at 89
  In D:\work\blocks\dsPIC_UART_Rx_Tx_Matlab_InitMask.p>dsPIC_UART_Rx_Tx_Matlab_InitMask at 9
  In general\private\openmdl at 13
  In open at 148
  In uiopen at 196
Warning: --- =========>  PORT A0 is used by at least two peripheral :  UART Rx and CAN
Bus.
> In D:\work\blocks\dsPIC_PortSetting.p>setTypePort at 638
  In D:\work\blocks\dsPIC_PortSetting.p>dsPIC_PortSetting at 399
  In D:\work\blocks\dsPIC_MASTER_callback.p>dsPIC_MASTER_callback at 89
  In D:\work\blocks\dsPIC_UART_Rx_Tx_Matlab_InitMask.p>dsPIC_UART_Rx_Tx_Matlab_InitMask at 9
  In general\private\openmdl at 13
  In open at 148
  In uiopen at 196
Warning: --- =========>  PORT A0 is used by at least two peripheral :  UART Rx and CAN
Bus.
> In D:\work\blocks\dsPIC_PortSetting.p>setTypePort at 638
  In D:\work\blocks\dsPIC_PortSetting.p>dsPIC_PortSetting at 400
  In D:\work\blocks\dsPIC_MASTER_callback.p>dsPIC_MASTER_callback at 89
  In D:\work\blocks\dsPIC_UART_Rx_Tx_Matlab_InitMask.p>dsPIC_UART_Rx_Tx_Matlab_InitMask at 9
  In general\private\openmdl at 13
  In open at 148
  In uiopen at 196
Warning: --- =========>  PORT A0 is used by at least two peripheral :  UART Rx and I2C
Bus.
> In D:\work\blocks\dsPIC_PortSetting.p>setTypePort at 638
  In D:\work\blocks\dsPIC_PortSetting.p>dsPIC_PortSetting at 462
  In D:\work\blocks\dsPIC_MASTER_callback.p>dsPIC_MASTER_callback at 89
  In D:\work\blocks\dsPIC_UART_Rx_Tx_Matlab_InitMask.p>dsPIC_UART_Rx_Tx_Matlab_InitMask at 9
  In general\private\openmdl at 13
  In open at 148
  In uiopen at 196
Warning: --- =========>  PORT A0 is used by at least two peripheral :  UART Rx and I2C
Bus.
> In D:\work\blocks\dsPIC_PortSetting.p>setTypePort at 638
  In D:\work\blocks\dsPIC_PortSetting.p>dsPIC_PortSetting at 463
  In D:\work\blocks\dsPIC_MASTER_callback.p>dsPIC_MASTER_callback at 89
  In D:\work\blocks\dsPIC_UART_Rx_Tx_Matlab_InitMask.p>dsPIC_UART_Rx_Tx_Matlab_InitMask at 9
  In general\private\openmdl at 13
  In open at 148
  In uiopen at 196
TLibrary detected, Fixed Step artificially set to 1ms
Warning: In instantiating linked block 'dsPIC_33f_Explorer16/Master' : Invalid setting
in Master block (mask) 'Master' for parameter 'MCLR'.
> In D:\work\blocks\dsPIC_ADC_callback_InitMask.p>dsPIC_ADC_callback_InitMask at 9
  In D:\work\blocks\dsPIC_UART_Rx_Tx_Matlab_InitMask.p>dsPIC_UART_Rx_Tx_Matlab_InitMask at 9
  In general\private\openmdl at 13
  In open at 148
  In uiopen at 196
***** Solver Mode change from Auto to SingleTasking (this mode allows single rate and multirate). See help to get the difference with the MultiTasking mode which is now supported by the blockset *****
new GMAKE path : C:\PROGRA~1\MATLAB\R2007b\bin\win32\gmake
file not found : C:\PROGRA~2\MICROC~1\mplabc30\v3.25\support\PIC24F\gld\p24fJ96GA010.gld
      --> corrected : find in --script=C:\PROGRA~1\MICROC~1\mplabc30\v3.25\support\PIC24F\gld\p24fJ96GA010.gld
file not found : C:\PROGRA~2\MICROC~1\mplabc30\v3.25\lib\libpic30-coff.a
      --> corrected : find in C:\PROGRA~1\MICROC~1\mplabc30\v3.25\lib\libpic30-coff.a
file not found : C:\PROGRA~2\MICROC~1\mplabc30\v3.25\lib\PIC24F\libpPIC24Fxxx-coff.a
      --> corrected : find in C:\PROGRA~1\MICROC~1\mplabc30\v3.25\lib\PIC24F\libpPIC24Fxxx-coff.a
file not found : C:\PROGRA~2\MICROC~1\mplabc30\v3.25\lib\libc-coff.a
      --> corrected : find in C:\PROGRA~1\MICROC~1\mplabc30\v3.25\lib\libc-coff.a
file not found : C:\PROGRA~2\MICROC~1\mplabc30\v3.25\lib\libm-coff.a
      --> corrected : find in C:\PROGRA~1\MICROC~1\mplabc30\v3.25\lib\libm-coff.a
directory not found : C:\Program Files\Microchip\mplabc30\v3.25\include
      --> corrected : find in C:\PROGRA~1\MICROC~1\mplabc30\v3.25\include
 


3 test have been performed now on .
Vista / XP / and Win7 by my collegue

they all gives the same error.


It's a pitty because your modules seems to be a really nice approach for prototyping.

Thanks
Sandra

LubinKerhuel
Site Admin - Expert
Posts: 616
Joined: Wed Mar 07, 2007 11:23 pm
Location: Marseille - France
Contact:

Re: PTsources files not found. MPLAB project file not create

Postby LubinKerhuel » Wed Sep 21, 2011 6:20 pm

Could you post the model on the forum ? (or by email is it's not to be published)

Lubin

abrixy
Posts: 3
Joined: Mon Sep 19, 2011 9:40 pm

Re: PTsources files not found. MPLAB project file not create

Postby abrixy » Thu Sep 22, 2011 11:04 am

It's the example model i downloaded from your website in the zip from the R2007b block-set.

I didn't make any change to it

As I have a explore 16 board I wanted to test on it .

Thanks
Sandra


Return to “bug reports”

Who is online

Users browsing this forum: No registered users and 1 guest