MPLAB X link post-compilation errors

bmairs
Posts: 69
Joined: Mon Jul 27, 2009 7:51 pm

MPLAB X link post-compilation errors

Postby bmairs » Fri Sep 09, 2011 7:31 pm

Clicking the MPLAB X link within MATLAB gives me an error and doesn't launch MPLAB X. The link for launching MPLAB 8, however, is correct.

Here is what I see at the end of compilation along with the errors. After compilation I clicked the MPLAB X link, then the MPLAB 8 link, then the MPLAB X link again, which is what the additional output shows.

Code: Select all

"    ---33fJ256GP710---"
"*** Created "executable": ..\../code_gen.cof"   
''pic30-bin2hex ..\../code_gen.cof 
"*** Converted code_gen.cof to code_gen.hex"   
.
"***  MPLAB: file -> import, choose code_gen.hex. Configure -> Configuration Bits : Verify !"
"       Download into the chip and run."      
### Successful completion of Real-Time Workshop build procedure for model: code_gen
***  You could open project created and (re)compile it :
        ==> MPLAB 8: Within Matlab, right-click code_gen.mcp -> open outside Matlab.
        ==> MPLAB X: Start MPLAB X, open the project folder C:\Users\Bryant\Projects\Autoboat\Code\basic_model\code_gen_dspic
???  disp('Starting MPLAB X...
          |
Error: A MATLAB string constant is not terminated properly.
 
Starting MPLAB 8...
Starting MPLAB 8...
???  disp('Starting MPLAB X...
          |
Error: A MATLAB string constant is not terminated properly.

LubinKerhuel
Site Admin - Expert
Posts: 616
Joined: Wed Mar 07, 2007 11:23 pm
Location: Marseille - France
Contact:

Re: MPLAB X link post-compilation errors

Postby LubinKerhuel » Mon Sep 12, 2011 7:55 pm

Thanks for bug report,

bug corrected in version 3.6c. Note however than MPLAB X do not open your project (like MPLAB 8). I do not know yet how to make this happend...

Lubin


Return to “bug reports”

Who is online

Users browsing this forum: No registered users and 1 guest