Error while compiling "dsPIC_33f_Explorer16.mdl"

Posts: 2
Joined: Thu Jun 03, 2010 8:38 am

Error while compiling "dsPIC_33f_Explorer16.mdl"

Postby Darlington » Thu Jun 03, 2010 9:33 am

Dear Mr Kerhuel,

First of all I would like to thank you for sharing with everyone the work you did. It is very helpful.

I am a beginner with MATLAB/Simulink for dsPIC. So my first try was to compile one of your model, the dsPIC_33f_Explorer16.mdl, with the toolbox you provide. Unfortunately I encountered the following problem while compiling (Error using ==> genMakefileAndBuild at 1070):

### Processing Template Makefile: C:\Documents and Settings\Simulator\Bureau\Camille\Installations\dspic\dspic_pic30_gcc.tmf
-- Bypassing matlab internal LCC configuration --
### Creating from C:\Documents and Settings\Simulator\Bureau\Camille\Installations\dspic\dspic_pic30_gcc.tmf
''pic30-gcc -c -mcpu=33fJ256GP710 -O3 -fschedule-insns -fschedule-insns2 -O -I. -I..\.. -IC:\PROGRA~1\MATLAB\R2007b/simulink/include -IC:\PROGRA~1\MATLAB\R2007b/extern/include -IC:\PROGRA~1\MATLAB\R2007b/rtw/c/src -IC:\PROGRA~1\MATLAB\R2007b/rtw/c/ert -IC:\PROGRA~1\MATLAB\R2007b/rtw/c/src/ext_mode/common -IC:\DOCUME~1\SIMULA~2\Bureau\Camille\TESTCA~2\DSPIC_~1\sources -IC:\DOCUME~1\SIMULA~2\Bureau\Camille\TESTCA~2 -IC:\PROGRA~1\MATLAB\R2007b\rtw\c\libsrc -I C:\PROGRA~1\MICROC~1\MPLABC~2\include dsPIC_33f_Explorer16_main.c
dsPIC_33f_Explorer16_main.c:41: error: syntax error before '&' token
dsPIC_33f_Explorer16_main.c: In function '_FICD':
dsPIC_33f_Explorer16_main.c:43: error: syntax error before '{' token
dsPIC_33f_Explorer16_main.c:50: error: syntax error before 'dsPIC_33f_Explorer16_SetEventsForThisBaseStep'
gmake: *** [dsPIC_33f_Explorer16_main.o] Error 255
### Real-Time Workshop build procedure for model: 'dsPIC_33f_Explorer16' aborted due to an error.

C30 Compiler found
C30 Compiler found

I tried to check the syntax in the generated code but found nothing wrong.
I am using MATLAB R2007b. I also tried to compile from MPLAB IDE but the problem is the same.
I checked my configuration parameters but I probably forgot something.

Could you please let me know if this problem is familiar to you, and if you have any clue to solve it?


Posts: 2
Joined: Thu Jun 03, 2010 8:38 am

Re: Error while compiling "dsPIC_33f_Explorer16.mdl"

Postby Darlington » Wed Jun 30, 2010 2:17 pm

Do you really have no clue about this error message?

Return to “Requirement, Installation & Configuration”

Who is online

Users browsing this forum: No registered users and 1 guest