SPI - IMU "2"

Create new topics, add your comment, remark, bugs...
Bobes
Posts: 36
Joined: Wed Nov 25, 2009 11:27 am
Location: Brno, CZE
Contact:

SPI - IMU "2"

Postby Bobes » Sat Feb 27, 2010 11:48 pm

Hello,
I am trying to use SPI: I have ADIS16405. I have tried scheme used in IMU, but I do not exactly understand what are the inputs? I guess they are addresses, but how to get to those numbers? (I am looking at the IMU_dsPIC_30f4012_TestElectronics.mdl)
I do not think that my problem is wiring, when I reset ADIS, I receive 2^16, otherwise its always zero, in some cases I have got 17.

"trame" is frame in french?
Attachments
Vejlupek_CAR4_dsPIC33_ACU44_SPI_R02.mdl
another way: IMU example like
gives me zero and 17 all the time, do not know why
(101.99 KiB) Downloaded 123 times
Vejlupek_CAR4_dsPIC33_ACU44_SPI_R01.mdl
one way
(97.29 KiB) Downloaded 127 times
ADIS16400_16405.pdf
memory map is on page 11
(496.69 KiB) Downloaded 127 times

Bobes
Posts: 36
Joined: Wed Nov 25, 2009 11:27 am
Location: Brno, CZE
Contact:

Re: SPI - IMU "2"

Postby Bobes » Sun Feb 28, 2010 12:28 am

update: i have changed back to the interrupt driven SPI bloc, and I am getting some data, just not on all channels and also they seems to be mixed. ie I am getting something that is reacting on my screwdriver (magnetic) but the readout is on accY
will work more, just in case someone see some ovious error that I am missing, please let me know .)
Attachments
Vejlupek_CAR4_dsPIC33_ACU44_SPI_R02.mdl
(62.34 KiB) Downloaded 139 times

Bobes
Posts: 36
Joined: Wed Nov 25, 2009 11:27 am
Location: Brno, CZE
Contact:

Re: SPI - IMU "2"

Postby Bobes » Fri Mar 19, 2010 9:34 pm

ok, uff, found the problem! its in the data-sheet, or I am an an-alphabet... I believe that AD have a bug in their data-sheet.
they have addresses for X-Z gyro X-Z accelerometer X-Z magnetometer like this: 0400 0600 0800 0A00 0C00 0E00 1000 1200 1400
But I am running it and finally reading data that make sense like this: 0400 0500 0600 0700 0800 0900 0A00 0B00 0C00 (or one less, I am not sure right now, I have the model at school)


Return to “General Remark and Questions”

Who is online

Users browsing this forum: No registered users and 1 guest