Search found 616 matches

by LubinKerhuel
Thu Jul 24, 2014 2:26 pm
Forum: bug reports
Topic: error compilation
Replies: 3
Views: 2431

Re: error compilation

Hi Zemog, I would recommend to use the new blockset we are developping now at Microchip. You might find a free demo version at http://www.microchip.com/SimulinkBlocks The current version is the V3.30 but a new version with many fixed issues will be release soon. You might also use the microchip foru...
by LubinKerhuel
Tue Sep 18, 2012 5:05 pm
Forum: bug reports
Topic: dsPIC_PWM_motor.tlc problem
Replies: 6
Views: 2256

Re: dsPIC_PWM_motor.tlc problem

Ok, Thanks for your feedback,

(As I am not very responsive at that time !)
We're preparing a new blockset suporting newer chips at Microhcip...
Lubin
by LubinKerhuel
Fri Jun 29, 2012 4:20 pm
Forum: Version compatibility issues
Topic: Matlab 2012
Replies: 2
Views: 1090

Re: Matlab 2012

Hello Michael, The blockset version for Matlab 2011b should works quite well with Matlab 2012a. I noticed one problem with the rs232gui interface which is corrected but not yet published. However, you might have a problem if you are using the latest Microchip compiler : xc16 or xc32. all theses tiny...
by LubinKerhuel
Sun Jun 10, 2012 5:54 pm
Forum: bug reports
Topic: dsPIC_PWM_motor.tlc problem
Replies: 6
Views: 2256

Re: dsPIC_PWM_motor.tlc problem

Thanks for bug report,

Will be fixed in next release.
Lubin
by LubinKerhuel
Fri Apr 27, 2012 1:37 am
Forum: bug reports
Topic: "link errors found"
Replies: 2
Views: 1207

Re: "link errors found"

Hi Emre,

Usually, / and \ would not be a problem for the Microchip C30 compiler.
Is si notmal you compiler path has two bin folders ?
c:\program files\microchip\mplab c30\bin\bin/pic30-coff-ld.exe

That might cause the link error ?

Lubin
by LubinKerhuel
Fri Apr 27, 2012 1:34 am
Forum: bug reports
Topic: Heap can't be configured for MPLAB
Replies: 1
Views: 877

Re: Heap can't be configured for MPLAB

Hello Bryant,

The compiler's parameters are not reported to the MPLAB project.
Thus you are completly true this is a problem.

Thanks for your remark.

Lubin
by LubinKerhuel
Fri Apr 27, 2012 1:31 am
Forum: bug reports
Topic: I2C does not build on PIC32
Replies: 3
Views: 1386

Re: I2C does not build on PIC32

Hello John,

As you probably noticed, I am pretty busy theses time.
It's would be difficult for me spend much time on this question.

However, if the problem is just one bit MI2C1IF whose name changed, I might solve it pretty easily.
Do you think the problem is limited to this ?

Lubin
by LubinKerhuel
Fri Apr 27, 2012 1:27 am
Forum: bug reports
Topic: Typing Error!
Replies: 1
Views: 908

Re: Typing Error!

Thanks Saeed,

Next version with all example updated.

Lubin
by LubinKerhuel
Fri Apr 27, 2012 1:22 am
Forum: General Remark and Questions
Topic: PWM motor output error
Replies: 16
Views: 6383

Re: PWM motor output error

Akwer,

Matlab is now case sensitive.
I corrected few problem caused by this change.

You might be using an old blockset version. Please update and let me know if the problem is still there.

The file dsPIC_PWM_Motor_callback_InitMask.p has M of Motor upper case in latest blockset release.

Lubin
by LubinKerhuel
Fri Apr 27, 2012 1:15 am
Forum: General Remark and Questions
Topic: SIM2LAB Blockset for dsPIC
Replies: 2
Views: 2532

Re: SIM2LAB Blockset for dsPIC

Hello,

SIM2LAB blockset is a "concurent" blockset.
You should find better feedback on their forum regarding their installation.

Alternatively, please try the "LK" blockset available on this website ;-)
http://www.kerhuel.eu/wiki/Download

Lubin
by LubinKerhuel
Fri Apr 27, 2012 1:13 am
Forum: General Remark and Questions
Topic: Error in SPWM Motor PWM Output
Replies: 3
Views: 2903

Re: Error in SPWM Motor PWM Output

Hello,

You will not generate a PWM efficiently using digital output blocks.
Use the PWM like block, or Output Compare block.

You might find some examples on the website or within blockset example folder.

Lubin
by LubinKerhuel
Mon Mar 26, 2012 11:32 am
Forum: dsPIC Peripherals
Topic: Wrong I2C output on UDB4 board
Replies: 2
Views: 1386

Re: Wrong I2C output on UDB4 board

Hello Lior, I just tested and I am getting exactly the same result. When I2C is beeing used, we should not see so many transition as there is no acknowledge from the other side. Something's might be wrong with the software. I did not see errata on this 33Fj256GP710A Chip rgarding I2C. You might try ...
by LubinKerhuel
Mon Mar 26, 2012 12:09 am
Forum: Request for new functions / Peripheral / Chip support
Topic: Please support 32MX320F128H
Replies: 3
Views: 1121

Re: Please support 32MX320F128H

Hello John, 32MX320 & 32MX340 chips are now added in latest version (3.7d). Modifying generated code is pretty easy through MPLAB as the MPLAB 8 or MPLAB X project are created with the source code. However, that might be quite complicated if chip is too different from an existing chip. Adding ne...
by LubinKerhuel
Mon Mar 05, 2012 11:01 am
Forum: Requirement, Installation & Configuration
Topic: Error(s) encountered while building model "ADC6"
Replies: 3
Views: 1826

Re: Error(s) encountered while building model "ADC6"

The _FICD register were renamed to _ICD is some compilers version (3.25, 3.30).

Latest compiler version set this register name to _FICD.
Please download latest C30 compiler (3.31) and perhaps remove others compilers version to make sure the blockset will choose automatically the latest one.

Lubin
by LubinKerhuel
Mon Feb 13, 2012 12:13 am
Forum: General Remark and Questions
Topic: error 255 - tcpip not found
Replies: 9
Views: 4701

Re: error 255 - tcpip not found

Hello,
that error should go to Microchip's compiler's team. I might help to reach them if you want.

Anyway, my feeling is that fuzzy logic is not a great for embedded system. It typically required too much memory or to evluate complex math functions...

Lubin
by LubinKerhuel
Sun Feb 12, 2012 9:51 am
Forum: General Remark and Questions
Topic: error 255 - tcpip not found
Replies: 9
Views: 4701

Re: error 255 - tcpip not found

Hello, TCP/Ip not found does not create an error. just a warning, not important. Your error is there : c:/program files/microchip/mplab c30/bin/bin/../../support/peripheral_24F/GenericTypeDefs.h:53: error: syntax error before '(' token typically, there are problems with boolean declaration. I though...
by LubinKerhuel
Mon Jan 23, 2012 12:49 am
Forum: bug reports
Topic: Interface Tx-Matlab rs232gui block fails in 2011b
Replies: 1
Views: 986

Re: Interface Tx-Matlab rs232gui block fails in 2011b

Thanks Bryant, I am used to open the GUI interface typing rs232gui at the matlab prompt. I will correct the block that just call this function when you open it. the workaround is to type directly at matlab prompt >> rs232gui. As you see, matlab 2011 is now case sensitive for function call. Lubin
by LubinKerhuel
Wed Jan 18, 2012 9:33 pm
Forum: bug reports
Topic: Failed compilation still generated MPLAB 8 project
Replies: 4
Views: 1421

Re: Failed compilation still generated MPLAB 8 project

Bryant, I am a bit confused. Could you described what you obtained and what you would like to obtain ? (I am not sure I could do it for this blockset, but it would be useful for next Microchip blockset) Currently, the model - generates a .mcp file (mplab 8 project) and - add into the directory creat...
by LubinKerhuel
Wed Jan 18, 2012 9:24 pm
Forum: General Remark and Questions
Topic: installation problems windows 7 64 bits
Replies: 4
Views: 2816

Re: installation problems windows 7 64 bits

Hello Stephan, Glad to hear from you and Salon de Provence team. Did you add two motors to your hexacopter to get an oktokopter ? Regarding the problem you mentionned, please make sure that the three blockset folders (root, \dspic and \blocks ) exist in the matlab path. You might type >>path rehash ...
by LubinKerhuel
Tue Jan 17, 2012 12:02 pm
Forum: bug reports
Topic: build error in GenericTypeDefs.h
Replies: 13
Views: 5976

Re: build error in GenericTypeDefs.h

Hello John, I could not spend too much time on this specific problem. Interfacing with other driver might be difficult. However, here is my finding: You copied two files : GenericTypeDefs.h timer.h in the Include folder that you include that are already included within the compiling process. Includi...
by LubinKerhuel
Mon Jan 16, 2012 9:13 pm
Forum: bug reports
Topic: Failed compilation still generated MPLAB 8 project
Replies: 4
Views: 1421

Re: Failed compilation still generated MPLAB 8 project

Hi Bryant,

This is done on purpose : It allows to find out why compilation breaks. For example, if the blockset mispell one fuse register, you might correct it this way quite easily.
However, depending where the compilation stops, you might have missing files...

Lubin
by LubinKerhuel
Sun Jan 15, 2012 11:20 pm
Forum: bug reports
Topic: Problem with rs232gui
Replies: 12
Views: 3759

Re: Problem with rs232gui

I attached here the binary to use the bootloader ds30 (from Mikael Gustafsson) with the UDB4 board: ds30_Bootloader_UDB4_Board_115200_UART2_ClkSwitchingEnable.zip ==> Load this .hex into the board using classical programmer ==> then, use the ds30 GUI interface to upload new .hex. (Bootloader will be...
by LubinKerhuel
Sun Jan 15, 2012 12:38 am
Forum: bug reports
Topic: Problem with rs232gui
Replies: 12
Views: 3759

Re: Problem with rs232gui

Lior, I did very first test with UDB4 board. the attach model send Rate gyro and Accelerometers values through UART correctly using appropriate PLL value. UDB4_TestBoard.mdl This is just for testing (plotting sensor in pseudo-real time). Note that baud rate used do not allow logging all 6 axis at 1k...
by LubinKerhuel
Sat Jan 14, 2012 9:02 pm
Forum: General Remark and Questions
Topic: how to use custom c source code
Replies: 9
Views: 4078

Re: how to use custom c source code

It works with the demo version or at least it should work ;-)
by LubinKerhuel
Thu Jan 12, 2012 7:44 pm
Forum: bug reports
Topic: Problem with rs232gui
Replies: 12
Views: 3759

Re: Problem with rs232gui

In Master block, is there any reason why the quartz is set to 14Mhz this time ?
It should be 8Mhz !

Try to make one led blinking at 1Hz.
If it's not blinking at 1Hz, you have a problem with the oscillator configuration (thus UART cant be set at the appropriate baud rate)

Lubin
by LubinKerhuel
Thu Jan 12, 2012 5:59 pm
Forum: General Remark and Questions
Topic: how to use custom c source code
Replies: 9
Views: 4078

Re: how to use custom c source code

Correct.
you might also add the folder where they are in the "include directory" box if the compiler did not find theses files.

Lubin
by LubinKerhuel
Thu Jan 12, 2012 3:17 pm
Forum: General Remark and Questions
Topic: how to use custom c source code
Replies: 9
Views: 4078

Re: how to use custom c source code

Hi John, That's not correct. File reference must be included into "Include list of additional". Otherwise, simulink will just add the name on the file within the generated code, that would create an error! Then, the files should be included into the Code Generation panel. Not the Simulatio...
by LubinKerhuel
Thu Jan 12, 2012 3:11 pm
Forum: bug reports
Topic: Problem with rs232gui
Replies: 12
Views: 3759

Re: Problem with rs232gui

Hello Lior,

I get one board. I am willing to use it for personal project but I am quite overloaded right now.
You have clock switch options (something like) in the Master block.

this board has a 8MhZ quartz, not a 7.5 MhZ ?

I2C is always difficult to set-up!

Lubin
by LubinKerhuel
Thu Jan 12, 2012 2:03 pm
Forum: bug reports
Topic: Problem with rs232gui
Replies: 12
Views: 3759

Re: Problem with rs232gui

I am willing to test this board.

First task for me is to embed a bootloader that would be quite practical.
I am planning to use the ds30 loader... then, using the clock switching option from the blockset, you could use the board very efficiently...

Lubin
by LubinKerhuel
Thu Jan 12, 2012 11:03 am
Forum: Request for new functions / Peripheral / Chip support
Topic: Support more inputs for C-function Call Block
Replies: 4
Views: 1320

Re: Support more inputs for C-function Call Block

I understand that the 3 input limitation might not be practical, however I think that using array probides some possibilities.

Everything is always possible, question of time...
Is it a show stopper for your project ?

Lubin
by LubinKerhuel
Thu Jan 12, 2012 11:01 am
Forum: bug reports
Topic: Problem with rs232gui
Replies: 12
Views: 3759

Re: Problem with rs232gui

Alpert, With your quartz and no PLL, you get a 1.73% error on the UART baud rate. This usually works but might be the problem(depending on your computer's hardware). Try to activete PLL and find a processor speed that would lower the UART baud rate error (below 1% should be Ok !). "2) I connect...
by LubinKerhuel
Thu Jan 12, 2012 10:51 am
Forum: Advanced Simulink & RTW Questions
Topic: Problem of configuring a dspic with Simulink Blockset
Replies: 7
Views: 2104

Re: Problem of configuring a dspic with Simulink Blockset

Alpert, This look like a problem with few compilers version as the FICD register were renamed as ICD. Some blockset version used FICD or ICD as register to comply with the latest compiler. please download the latest C30 (v3.31) compiler version and the latest blockset (v3.7c) Everything should works...
by LubinKerhuel
Thu Jan 12, 2012 10:48 am
Forum: General Remark and Questions
Topic: problem with simulation time step, mips & measured freq
Replies: 1
Views: 1631

Re: problem with simulation time step, mips & measured freq

Leonardo, Thanks for your question. I mostly used the chips with an external quartz. I think that the blockset suport for the internal oscillator is pretty weak and I would not provide any garanty... I joined Microchip to build-up a new blockset. This new blockset will handle differents oscillators ...
by LubinKerhuel
Thu Jan 12, 2012 10:36 am
Forum: General Remark and Questions
Topic: how to use custom c source code
Replies: 9
Views: 4078

Re: how to use custom c source code

Hi John, I couldn't find "Simulation Parameters -> Real time workshop -> additional C file" on matlab 2011b. The help file seems not up to date (or I write something wrong, anyway, I think this comes from an older matlab version...) The correct place to add the file is the one you provided...
by LubinKerhuel
Thu Jan 12, 2012 10:23 am
Forum: General Remark and Questions
Topic: dsPIC Master error
Replies: 12
Views: 5638

Re: dsPIC Master error

Compiler C30 v3.31 is released.
Blockset were updated accordingly. Download latest blockset version (3.7c) with the C30 compiler v3.31.

Everything should be Ok now.
Lubin
by LubinKerhuel
Mon Dec 19, 2011 1:46 pm
Forum: General Remark and Questions
Topic: dsPIC Master error
Replies: 12
Views: 5638

Re: dsPIC Master error

This is correct.

ICD will turn back to FICD in next Microchip compiler (v3.31) comming soon.
Thus I do not correct this problem for now.

Lubin
by LubinKerhuel
Mon Dec 19, 2011 1:43 pm
Forum: bug reports
Topic: Problem with rs232gui
Replies: 12
Views: 3759

Re: Problem with rs232gui

Alpert, you might try to press the Raw data button in the rs232gui interface. No decoding will be done, you should get 1 control byte, and 1 value 1 control byte, 1 value etc.... Check that control byte is constant value, and that value is moving correctly (as it is an uint8, it does not need "...
by LubinKerhuel
Thu Dec 15, 2011 9:12 am
Forum: General Remark and Questions
Topic: Problem with Flag Output of UART RX Block
Replies: 3
Views: 3161

Re: Problem with Flag Output of UART RX Block

Hello,

There is no know caveeats until now.
Your description is very clear, thanks for it.
Would it be possible to upload your model on the forum (or an equivalent model creating that problem) ? It will help to find out what's going on.

Thanks,
Lubin
by LubinKerhuel
Tue Dec 06, 2011 10:57 pm
Forum: bug reports
Topic: MPLAB 8.x project not generated properly during compile
Replies: 6
Views: 2076

Re: MPLAB 8.x project not generated properly during compile

I might test compiling your project on my system if that's not too huge.

Lubin
by LubinKerhuel
Mon Dec 05, 2011 11:26 am
Forum: bug reports
Topic: MPLAB 8.x project not generated properly during compile
Replies: 6
Views: 2076

Re: MPLAB 8.x project not generated properly during compile

Hello Bryant,

I tested a tiny model with two c files declared as follow: (Code Generation - Custom Code - additional Source files):

Code: Select all

..\..\CFunctionCall\MyCFunction.c
test/myfunction2.c

I could not reproduce the problem.

Which blockset version do you currently have ?

Lubin
by LubinKerhuel
Sat Oct 08, 2011 4:31 pm
Forum: bug reports
Topic: restorePath, and slbuild errors, matlab working directory ch
Replies: 8
Views: 2810

Re: restorePath, and slbuild errors, matlab working director

I confirm that the blockset was corrupting mathworks error message making model's error very difficult to handle.
Fixed in blockset release 3.7.

Thanks for reporting that bug, it really worth it !

Lubin
by LubinKerhuel
Sat Oct 08, 2011 12:58 am
Forum: Advanced Simulink & RTW Questions
Topic: RS232 DATA TRANSFER
Replies: 2
Views: 1173

Re: RS232 DATA TRANSFER

Ismael, All my bad for the very long delay. Here is one of my old model where I logged IMU data from a RC airplane (through High range BlueTooth). Data from IMU sensor were logged at 1Khz I remember while RC receiver set point (refreshed at 50Hz) were sent at much lower frequency. Some data are pack...
by LubinKerhuel
Sat Oct 08, 2011 12:33 am
Forum: bug reports
Topic: restorePath, and slbuild errors, matlab working directory ch
Replies: 8
Views: 2810

Re: restorePath, and slbuild errors, matlab working director

Hi John The good news is that I can reproduce the error with windows x64, matlab x64. I think I get it : Multiply block (X) does not support boolean type at its output. Digital Output Write block after Multiply block is a boolean. For some reason, the error message is silly and my guess is that the ...
by LubinKerhuel
Sat Oct 08, 2011 12:05 am
Forum: Requirement, Installation & Configuration
Topic: Required Matlab components
Replies: 4
Views: 1443

Re: Required Matlab components

Thus EC works on top of Matlab Coder ?

Thanks Mathworks ;-)
Lubin
by LubinKerhuel
Wed Sep 21, 2011 6:20 pm
Forum: bug reports
Topic: PTsources files not found. MPLAB project file not created.
Replies: 4
Views: 1526

Re: PTsources files not found. MPLAB project file not create

Could you post the model on the forum ? (or by email is it's not to be published)

Lubin
by LubinKerhuel
Wed Sep 21, 2011 7:34 am
Forum: bug reports
Topic: PTsources files not found. MPLAB project file not created.
Replies: 4
Views: 1526

Re: PTsources files not found. MPLAB project file not create

Hi Sandra,

Could you post the complete message you get when compilint (all lines written at matlat command windows).
Are you compiling a model from the example directory or is it your own model ? if so, please upload it on the forum.

Lubin
by LubinKerhuel
Sat Sep 17, 2011 6:24 pm
Forum: General Remark and Questions
Topic: fuzzy logic controlller
Replies: 3
Views: 2131

Re: fuzzy logic controlller

Hi Ricardo, I could not open the fuzzy-logic block of yoru model as I do not have the Fuzzy-Logic Toolbox. Anyway, The model seems fine otherwise. Usually, theses fuzzy-logic blocks use a lot of memory as they implement huge look-up table for sigmoide function or similar. Could you copy-past the err...
by LubinKerhuel
Mon Sep 12, 2011 7:55 pm
Forum: bug reports
Topic: MPLAB X link post-compilation errors
Replies: 1
Views: 1057

Re: MPLAB X link post-compilation errors

Thanks for bug report,

bug corrected in version 3.6c. Note however than MPLAB X do not open your project (like MPLAB 8). I do not know yet how to make this happend...

Lubin
by LubinKerhuel
Fri Sep 09, 2011 5:13 pm
Forum: General Remark and Questions
Topic: dsPIC Master error
Replies: 12
Views: 5638

Re: dsPIC Master error

There is
Real Time Workshop and
Real Time Workshop Embedded Coder (renamed Embedded Coder on last matlab version)

RTW EC works on top of RTW. In other word, you need them both.
Do you have RTW Embedded Coder ?

Lubin

Go to advanced search